Entrust Certificate Services Support Knowledge Base
Audience: General
Last Modified: 2009-05-26 15:23:40.0
TN 7814 - When creating a Unified Communication Certificate through the Certificate Management Interface, why do I receive an invalid domain error?
Problem:
During a Unified
Communication Certificate creation through the Entrust Certificate Management
Interface, you receive an error that there is an invalid domain in your CSR and
that you do not have the permission to create certificates for this domain. The
interface does not allow you to create the certificate.
Cause:
The domain or host
name that you have included in your Certificate Request is not a pre-approved
domain on the managed account.
Solution:
Review the command
that you used to create your Certificate Request. Make sure that the root
domains for the common name and and Subject Alternative Names (SANs) have been added to
your account through the domain management utility.
For example, the
following command was used to create a CSR:
New-ExchangeCertificate
-GenerateRequest -SubjectName "c=US,
o=Entrust Inc, cn=mail.entrust.com"
-DomainName autodiscover.entrust.com,autodiscover.entrust.net,
mail, localhost -privatekeyexportable $true -Path
c:\certReq.txt
The following
root domains/host names should be included on your account domain
list:
-entrust.com
-entrust.net
-mail
-localhost
To see your
pre-approve domain list:
1 - Click on Admin
Tools
2 - Click on Client
Management
3 - Click the edit
button beside the client
4 - Click the Client
Domain Information tab
You will see all of
your domains listed here. If you want to add one, simply enter it into one of
the empty boxes and hit submit request. The domain will be sent to Entrust for
approval and you will be notified when it has been added.
Affected Products:
- Entrust Certificate Services UCC SSL - 1 year Version Not Applicable English Windows