Entrust Datacard

Entrust Certificate Services Support Knowledge Base

Last Modified: 2017-08-16 14:13:01.0

Why do I receive the error ''Unable to configure RSA server private key''?

Article Number: 45635

User-added image

When you try to run Apache, you may receive one of the following error messages in the log file:

Unable to configure RSA server private key

mod_ssl: Init: (www.domain.com:443) Unable to configure RSA server private key (OpenSSL library error follows)

OpenSSL: error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch
 
Error: "Unable to configure RSA server private key"
Eror: "mod_ssl: Init: (www.domain.com:443) Unable to configure RSA server private key (OpenSSL library error follows)"
Error: "OpenSSL: error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch"

Cause: 
This problem may occur if the private key and certificate do not match.

Here is the Solution: 
To resolve this problem, specify the correct private key for the certificate. Compare the modulus of certificate against the modulus of the private key to see if they match. Follow these steps:

View the certificate modulus using the following command:

openssl x509 -noout -text -in certfile -modulus


View the key using the following command:

openssl rsa -noout -text -in keyfile -modulus

Verify the following:
Verify that the certificate and private key file is saved in Notepad and that it has no trailing spaces.

The "modulus" and "public exponent" portions in the key and the certificate must match exactly.
Make sure you aren't using the default server.key file.

You should also check the httpd.conf file to make sure that the directives are pointing to the correct private key and certificate.

If they do not match, you will have to reissue your certificate.

If you have any questions or concerns please contact the Entrust Certificate Services Support department for further assistance: 

Hours of Operation: 
Sunday 8:00 PM ET to Friday 8:00 PM ET 
North America (toll free): 1-866-267-9297 
Outside North America: 1-613-270-2680 (or see the list below) 
NOTE: Smart Phone users may use the 1-800 numbers shown in the table below.
Otherwise, it is very important that international callers dial the UITF format exactly as indicated. Do not dial an extra "1" before the "800" or your call will not be accepted as an UITF toll free call. 

CountryNumber
Australia0011 - 800-3687-7863
1-800-767-513
Austria00 - 800-3687-7863
Belgium00 - 800-3687-7863
Denmark00 - 800-3687-7863
Finland990 - 800-3687-7863 (Telecom Finland)
00 - 800-3687-7863 (Finnet)
France00 - 800-3687-7863
Germany00 - 800-3687-7863
Hong Kong001 - 800-3687-7863 (Voice)
002 - 800-3687-7863 (Fax)
Ireland00 - 800-3687-7863
Israel014 - 800-3687-7863
Italy00 - 800-3687-7863
Japan001 - 800-3687-7863 (KDD)
004 - 800-3687-7863 (ITJ)
0061 - 800-3687-7863 (IDC)
Korea001 - 800-3687-7863 (Korea Telecom)
002 - 800-3687-7863 (Dacom)
Malaysia00 - 800-3687-7863
Netherlands00 - 800-3687-7863
New Zealand00 - 800-3687-7863
0800-4413101
Norway00 - 800-3687-7863
Singapore001 - 800-3687-7863
Spain00 - 800-3687-7863
Sweden00 - 800-3687-7863 (Telia)
00 - 800-3687-7863 (Tele2)
Switzerland00 - 800-3687-7863
Taiwan00 - 800-3687-7863
United Kingdom00 - 800-3687-7863
0800 121 6078
+44 (0) 118 953 3088

TN5892

Affected Products:

  • Entrust Certificate Services 1 Year Advantage SSL Certificate Version Not Applicable Language Not Applicable Platform Not Applicable
  • Entrust Certificate Services 1 Year SSL Certificate Version Not Applicable Language Not Applicable Platform Not Applicable
  • Entrust Certificate Services 2 Year Advantage SSL Certificate Version Not Applicable Language Not Applicable Platform Not Applicable
  • Entrust Certificate Services 2 Year SSL Certificate Version Not Applicable Language Not Applicable Platform Not Applicable
  • Entrust Certificate Services Cert Admin Advantage Server Certificate 1 Year Version Not Applicable Language Not Applicable Platform Not Applicable
  • Entrust Certificate Services Cert Admin Advantage Server Certificate 2 Year Version Not Applicable Language Not Applicable Platform Not Applicable