Entrust Datacard

Entrust Certificate Services Support Knowledge Base

Last Modified: 2016-07-05 15:19:19.0

How do I resolve the error: "Keystore was tampered with, or password was incorrect"

Article Number: 42955

Servers affected: Jakarta Tomcat

Issue:

When you try to start up Tomcat from command line, you may encounter the following error message:

      Error: "Keystore was tampered with, or password was incorrect"

Cause:

This will occur if you copied your keystore file from an existing Tomcat server to another Tomcat server and did not update the server.xml file for the keystore file.

Resolution:

- Edit the server.xml file with the proper keystore file password.

- Save the server.xml file.

- Restart Tomcat web server.

TN5719

Affected Products:

  • Entrust Certificate Services 1 Year Advantage SSL Certificate Version Not Applicable Language Not Applicable Platform Not Applicable
  • Entrust Certificate Services 1 Year SSL Certificate Version Not Applicable Language Not Applicable Platform Not Applicable
  • Entrust Certificate Services 2 Year Advantage SSL Certificate Version Not Applicable Language Not Applicable Platform Not Applicable
  • Entrust Certificate Services 2 Year SSL Certificate Version Not Applicable Language Not Applicable Platform Not Applicable
  • Entrust Certificate Services Cert Admin Advantage Server Certificate 1 Year Version Not Applicable Language Not Applicable Platform Not Applicable
  • Entrust Certificate Services Cert Admin Advantage Server Certificate 2 Year Version Not Applicable Language Not Applicable Platform Not Applicable