Entrust Certificate Services Support Knowledge Base
Audience: Administrator
Last Modified: 2009-10-01 16:19:15.0
TN 5691 - How do I resolve the error - "Cannot connect to Citrix server. The server certificate received is not trusted (SSL-error 61)"
Servers affected: Windows 2000 (IIS 5.0) and Windows 2003 (IIS 6.0)
Issue:
When trying to connect to the Citrix server through Citrix secure gateway, you may receive the following error:
"Cannot connect to Citrix server. The server certificate received is not trusted (SSL-error 61)"
Cause:
You may encounter this error since the Citrix server does not come with the Entrust Root CA certificate in the CA store location.
Resolution:
The Entrust Root CA certificate should be installed into the root CA certificate store.
To Download an Entrust Root Certificate follow these steps:
1 – navigate to https://www.entrust.net/downloads/root_index.cfm
2 – select Personal Use and click on download certificates
3 – Select the required root(s) and download
Affected Products:
- Entrust Certificate Services 1 Year Advantage SSL Certificate Version Not Applicable Language Not Applicable Platform Not Applicable
- Entrust Certificate Services 1 Year SSL Certificate Version Not Applicable Language Not Applicable Platform Not Applicable
- Entrust Certificate Services 2 Year Advantage SSL Certificate Version Not Applicable Language Not Applicable Platform Not Applicable
- Entrust Certificate Services 2 Year SSL Certificate Version Not Applicable Language Not Applicable Platform Not Applicable
- Entrust Certificate Services Cert Admin Advantage Server Certificate 1 Year Version Not Applicable Language Not Applicable Platform Not Applicable
- Entrust Certificate Services Cert Admin Advantage Server Certificate 2 Year Version Not Applicable Language Not Applicable Platform Not Applicable
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