Entrust Datacard

Entrust Certificate Services Support Knowledge Base

Last Modified: 2016-07-05 15:15:31.0

How do I resolve the error “You submitted a CSR that contains an invalid country code”?

Article Number: 45599

Problem:

When I try to submit a CSR to Entrust Datacard Cloud Services, I get the following error:

You submitted a CSR that contains an invalid country code.

Cause:

This error will occur if the country code specified in the Certificate Signing Request (CSR) is a restricted country or does not exist.

 

Solution:

If the CSR is from a restricted country, Entrust Datacard Cloud Services will not be able to issue the user a certificate. Also, double check the ISO country code for the country code entered in the CSR (Certificate Signing Request).  Please generate a new CSR to create the correct value.

As an example:  Country=UK is not correct,  Country=GB is correct

TN5668

Affected Products:

  • Entrust Certificate Services 1 Year Advantage SSL Certificate Version Not Applicable Language Not Applicable Platform Not Applicable
  • Entrust Certificate Services 1 Year SSL Certificate Version Not Applicable Language Not Applicable Platform Not Applicable
  • Entrust Certificate Services 2 Year Advantage SSL Certificate Version Not Applicable Language Not Applicable Platform Not Applicable
  • Entrust Certificate Services 2 Year SSL Certificate Version Not Applicable Language Not Applicable Platform Not Applicable
  • Entrust Certificate Services Cert Admin Advantage Server Certificate 1 Year Version Not Applicable Language Not Applicable Platform Not Applicable
  • Entrust Certificate Services Cert Admin Advantage Server Certificate 2 Year Version Not Applicable Language Not Applicable Platform Not Applicable