Entrust Datacard

Entrust Certificate Services Support Knowledge Base

Last Modified: 2016-07-05 09:37:15.0

How do I resolve the error "Cannot install the certificate because it does not match the certificate requested".

Article Number: 45723

Servers effected: Apache (mod_ssl and open_ssl and Tomcat)

Issue:

When installing the Entrust Datacard server certificate, you may get the following error message:

     Error: "Cannot install the certificate because it does not match the certificate requested."

 

Resolution:

There are three possible causes for this error, please check each of the following below:

1. To install SSL you need to attach a Private key to a Public Key (Certificate file), check if you are using the correct files by doing the following:

Open the file you are using, and check that it is not your certificate request file, which would contains a -----BEGIN NEW CERTIFICATE REQUEST-----  and a ----END NEW CERTIFICATE REQUEST----- lines.


You should be attaching a private key file to the certificate.
This file format is in a .key format (hexadecimal (binary) format) and not a text format.

2. This error will also occur if you are not attaching the certificate to the correct private key file.

3. This error will also occur if you have just recently renewed the certificate and trying to install the old certificate on the new key pair.


 

TN5552

Affected Products:

  • Entrust Certificate Services 1 Year SSL Certificate Version Not Applicable Language Not Applicable Platform Not Applicable
  • Entrust Certificate Services 2 Year SSL Certificate Version Not Applicable Language Not Applicable Platform Not Applicable