Entrust Datacard

Entrust Certificate Services Support Knowledge Base

Last Modified: 2016-07-05 15:18:57.0

How do I resolve the error: "Certificate has expired or is not yet valid"?

Article Number: 45712

Issue:

After installing your SSL certificate onto the web server. You may get the following error message when browsing to your secured site:

Error message: The certificate has expired or is not yet valid

Resolution:

Change system clock to reflect today’s date.  This error is showing because the system clock is not Today’s Date.

Steps to Correct:

-Under Start Menu. Select Settings - Control Panel - Date/Time.

-Ensure date and time are current.

TN5508

Affected Products:

  • Entrust Certificate Services 1 Year Advantage SSL Certificate Version Not Applicable Language Not Applicable Platform Not Applicable
  • Entrust Certificate Services 1 Year SSL Certificate Version Not Applicable Language Not Applicable Platform Not Applicable
  • Entrust Certificate Services 2 Year Advantage SSL Certificate Version Not Applicable Language Not Applicable Platform Not Applicable
  • Entrust Certificate Services 2 Year SSL Certificate Version Not Applicable Language Not Applicable Platform Not Applicable
  • Entrust Certificate Services Cert Admin Advantage Server Certificate 1 Year Version Not Applicable Language Not Applicable Platform Not Applicable
  • Entrust Certificate Services Cert Admin Advantage Server Certificate 2 Year Version Not Applicable Language Not Applicable Platform Not Applicable